Follow

What are the Minimum Requirements for SafeCentral Mobile Security for Android?

Any Smartphone or Tablet running Android Version 3.2 or Higher.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk