Follow

SafeCentral compatibility with Windows 10

SafeCentral version 3.1.41.4236 and above will be Windows 10 compatible (build 10240 only supported; earlier versions are not supported). Windows 10 build 15063 is currently not compatible on all computers. This issue will be fixed in a new version of SafeCentral.

The SafeCentral plugin will be available in Internet Explorer 11. The SafeBrowser is based off the IE11 technology as well. The IE11 version is 11.0.10240.16384.

The SafeCentral plugin will not be available in the new Edge browser.

Check build of Windows 10 (Winver method)

  1. To launch it, you can tap the Windows key, type “winver” into the Start menu, and press Enter.
  2. You could also press Windows Key + R, type “winver” into the Run dialog, and press Enter.

Check build of Windows 10 (System method)

  1. Click or tap the Start button and select Settings
  2. Navigate to System > About and scroll down. You’ll see the “Version” and “Build” numbers here.
  3. Look at the “Version” and “OS Build” lines. If you have the original version of Windows 10, you’ll just see “OS Build 10240”. If you have the “November Update” version of Windows 10 - it will say OS Build 10586.29.

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk